If Apple really wants to support Pros they should make High Sierra compatible with MacPro 4,1's!

So Apple showed off their next OS High Sierra today at WWDC, with Metal 2 for more graphics acceleration.

Well if they want to prove that they are supporting Pro users as they make a new Mac Pro and work on their iMac Pro, they should re-open the os to 4,1 MacPro's and continue to support 5,1's until the new models come out. They killed 4,1 support with Sierra (though users can hack their 4,1's to becone 5,1's but it is not officially supported!

The new iMac Pro looks amazing, but I still don't want an all in one, get that new Mac Pro out soon!

EDIT: So they will continue to support the 5,1 but they should expand their support back as a sign of goodwill to Pro Users!
Comments
See Older Posts...
Jonah Lee .com